증상: 


잘 사용하고 있던 프로젝트가 어느 순간 갑자기 링크 에러로 빌드가 실패했다.


컴파일이 끝난 후 링킹 과정에서 한참 동안 응답이 없기 때문에 문제 파악이 힘들었다.


1>------ 빌드 시작: 프로젝트: XXXXXXXX, 구성: Debug Win32 ------

1>  LINK : F:\XXXX\...\XXXX.exe을(를) 찾을 수 없거나 마지막 증분 링크에 의해 빌드되지 않았습니다. 전체 링크를 수행하고 있습니다.

1>

1>LINK : fatal error LNK1000: Internal error during IMAGE::Pass1

1>

1>    Version 14.00.23918.0

1>

1>    ExceptionCode            = C0000006

1>    ExceptionFlags           = 00000000

1>    ExceptionAddress         = 602FDBE0 (602F0000) "C:\WINDOWS\SYSTEM32\VCRUNTIME140.dll"

1>    NumberParameters         = 00000003

1>    ExceptionInformation[ 0] = 00000000

1>    ExceptionInformation[ 1] = FEA18AEA

1>    ExceptionInformation[ 2] = C0000185

1>

1>  CONTEXT:

1>    Eax    = FEA18B26  Esp    = 0019E790

1>    Ebx    = 0019E7E4  Ebp    = 0019E7B4

1>    Ecx    = 0000003C  Esi    = FEA18AEA

1>    Edx    = 00000001  Edi    = 0019E7E4

1>    Eip    = 602FDBE0  EFlags = 00010202

1>    SegCs  = 00000023  SegDs  = 0000002B

1>    SegSs  = 0000002B  SegEs  = 0000002B

1>    SegFs  = 00000053  SegGs  = 0000002B

1>    Dr0    = 00000000  Dr3    = 00000000

1>    Dr1    = 00000000  Dr6    = 00000000

1>    Dr2    = 00000000  Dr7    = 00000000

========== 빌드: 성공 0, 실패 1, 최신 0, 생략 0 ==========



구글링을 해 보니 한 때 구버전 비주얼스튜디오 자체 버그가 있어서 핫픽스를 통해 해결이 가능했던 것으로 보였다.


그러나 내가 사용하는 환경은 Visual Studio 2015 Community 최신 버전이었기 때문에 별 도움이 안 됐다.


다음과 같이 관련된 몇 개의 글이 있었지만 문제를 해결할 수 없었다.


https://github.com/nanomsg/nanomsg/issues/472


https://support.microsoft.com/en-us/kb/826326


같은 프로젝트를 Visual Studio 2010으로 빌드해보아도 동일한 실패 현상을 겪었다.





해결:


해당 프로젝트는 OpenCV를 사용하는 프로젝트였는데, 추가 라이브러리로 지정된 OpenCV 경로가 다른 하드디스크(E:\)로 되어있었다.


나중에 알고보니 하드디스크 케이블에 문제가 생겨서 읽기/쓰기가 정상적으로 이루어지지 않고 있었다.


때문에 링커에서 라이브러리에 연결을 시도해도 디스크가 응답하지 않아서 에러가 생겼던 것이다.


하드디스크 케이블을 다른 것으로 교체한 후 디스크 작동이 정상적으로 이루어지는 것을 확인한 다음 다시 빌드를 시도했더니


LNK1000 링크 에러가 생기던 문제가 말끔히 해결되었다.

저작자 표시 비영리 동일 조건 변경 허락
신고
Posted by Kugi

댓글을 달아 주세요




OpenCV3.0.0 정적 라이브러리(Static Library)를 사용하도록 하여 release 모드로 빌드한 영상처리 어플리케이션을 내 컴퓨터가 아닌 다른 PC에서 테스트해봤는데


프로그램 실행까지는 정상적으로 되었는데 비디오 파일(.mp4)을 열려고 하면 실패하였다. 파일 경로의 문제는 아니었는데 코덱 문제일까 싶어서 좀 찾아봤더니

(http://answers.opencv.org/question/56519/opencv-24-static-lib-relies-on-opencv_ffmpegdll-on-windows/)


FFMPEG 라이브러리 때문에 생기는 문제였다.


FFMPEG 라이브러리는 GPL 라이선스를 적용받기 때문에 이 라이브러리를 정적으로 포함하도록 빌드할 경우 모든 소스코드가 똑같이 GPL 라이선스를 적용받아야 한다.


때문에 BSD 라이선스를 적용한 OpenCV는 이 FFMPEG 라이브러리를 동적으로 연결해서 사용하도록(DLL) 되어있다.


즉, 내가 다른 PC에서 테스트할 때 FFMPEG 라이브러리는 설치하지 않았기 때문에 비디오 파일을 열 때 실패하게 된 것이다.


release 된 .exe 파일과 같은 경로에 opencv_ffmpeg300.dll 파일을 넣어주었더니 제대로 비디오 파일을 여는 데 성공했다.


opencv_ffmpeg300.dll 파일은 다음과 같이 OpenCV bin 폴더 내에 들어있다.






참고로 OpenCV를 정적으로 빌드하기 위해서는 추가 종속성(Additional Dependencies)에 OpenCV의 staticlib 내의 라이브러리 파일들 뿐만 아니라


다음과 같은 추가적인 라이브러리 파일 입력이 필요하다. (x86 시스템 기반 기준)

 - comctl32.lib

 - vfw32.lib



개발환경은 Windows 8.1 Pro K, Visual Studio 2013 Professional 이며 C++를 사용했다.

테스트했던 PC는 Windows 7 Enterprise이다.



나중에 편리하게 사용하기 위해 전체 입력을 여기에 기록했다.

comctl32.lib

vfw32.lib

IlmImf.lib

ippicvmt.lib

libjasper.lib

libjpeg.lib

libpng.lib

libtiff.lib

libwebp.lib

opencv_calib3d300.lib

opencv_core300.lib

opencv_features2d300.lib

opencv_flann300.lib

opencv_hal300.lib

opencv_highgui300.lib

opencv_imgcodecs300.lib

opencv_imgproc300.lib

opencv_ml300.lib

opencv_objdetect300.lib

opencv_photo300.lib

opencv_shape300.lib

opencv_stitching300.lib

opencv_superres300.lib

opencv_ts300.lib

opencv_video300.lib

opencv_videoio300.lib

opencv_videostab300.lib

zlib.lib


저작자 표시 비영리 동일 조건 변경 허락
신고
Posted by Kugi

댓글을 달아 주세요

  1. 2015.07.22 16:44  댓글주소  수정/삭제  댓글쓰기

    비밀댓글입니다




Problem: 

11-13 15:08:17.982: E/dalvikvm(6149): dlopen("/data/app-lib/com.kugistory-1/libkugistory.so") failed: dlopen failed: cannot locate symbol "rand" referenced by "libkugistory.so"...

11-13 15:08:17.982: W/dalvikvm(6149): Exception Ljava/lang/UnsatisfiedLinkError; thrown while initializing Lcom/kugistory/NativeImageProcessor;

11-13 15:08:17.982: D/AndroidRuntime(6149): Shutting down VM

11-13 15:08:17.982: W/dalvikvm(6149): threadid=1: thread exiting with uncaught exception (group=0x41b10ba8)

11-13 15:08:17.992: E/AndroidRuntime(6149): FATAL EXCEPTION: main

11-13 15:08:17.992: E/AndroidRuntime(6149): Process: com.kugistory, PID: 6149

11-13 15:08:17.992: E/AndroidRuntime(6149): java.lang.UnsatisfiedLinkError: dlopen failed: cannot locate symbol "rand" referenced by "libkugistory.so"...

11-13 15:08:17.992: E/AndroidRuntime(6149): at java.lang.Runtime.loadLibrary(Runtime.java:364)

11-13 15:08:17.992: E/AndroidRuntime(6149): at java.lang.System.loadLibrary(System.java:526)

11-13 15:08:17.992: E/AndroidRuntime(6149): at com.kugistory.NativeImageProcessor.<clinit>(NativeImageProcessor.java:8)


안드로이드 네이티브(native) 라이브러리를 사용하려다가 위와같은 에러가 생겼다.


찾아보니 ndk-r10의 버그인 듯 하다.


다음과 같은 어떤 사람의 말로는 32-bit, 64-bit 빌드 타입과 관련된 문제인 듯 하다.

You need to use the 32-bit NDK (android-ndk32-r10b-darwin-x86_64) if building for 32-bit targets.

In the ARM headers in the 32-bit target NDK, rand() is declared as a static inline function (and as such does not need to exist as a symbol in libc.so on ARM devices).

In the ARM headers in the 64-bit target NDK, rand() is declared as a regular function, but since it does not exist in the libc.so on ARM devices, there is a runtime error.

Ergo, use the 32-bit target NDK when targeting 32-bit platforms. Or tell Google that their shit is broken.



Trials:

이것을 stl static 라이브러리에서 shared 라이브러리 이용으로 바꾸면 된다는 말을 지나가다가 보고는 다음과 같이 시도했으나 실패했다.


더보기 (Open)






Solution:


해결 방법을 찾는것은 매우 힘들었지만, 해결 방법 자체는 간단했다.


다음과 같이 Application.mk에서 대상 OS들을 몇가지 더 추가하자 거짓말처럼 문제가 풀렸다.


APP_STL := gnustl_static

APP_CPPFLAGS := -frtti -fexceptions

APP_ABI := armeabi armeabi-v7a x86 mips # arm64-v8a x86_64 mips64

APP_PLATFORM := android-16

APP_OPTIM := release

NDK_TOOLCHAIN_VERSION := 4.8



참고로 Android.mk는 다음과 같이 설정해둔 상태였다.

OpenCV를 위한 설정 등 없어도 되는 줄들도 포함되어 있다.

LOCAL_PATH := $(call my-dir)


include $(CLEAR_VARS)


OPENCV_INSTALL_MODULES:= on

OPENCV_CAMERA_MODULES:= off

OPENCV_LIB_TYPE:= STATIC


include E:\OpenCV-2.4.9-android-sdk\sdk\native\jni\OpenCV.mk


LOCAL_MODULE    := Kugistory


FILE_LIST := $(wildcard $(LOCAL_PATH)/*.cpp)

LOCAL_SRC_FILES := $(FILE_LIST:$(LOCAL_PATH)/%=%) 

LOCAL_C_INCLUDES += $(NDK_ROOT)/sources/cxx-stl/gnu-libstdc++/4.6/include

LOCAL_C_INCLUDES += $(NDK_ROOT)/sources/cxx-stl/gnu-libstdc++/4.6/libs/armeabi-v7a/include

LOCAL_C_INCLUDES += $(NDK_ROOT)/sources/cxx-stl/gnu-libstdc++/4.6/libs/armeabi-v7a-hard/include

LOCAL_LDLIBS += $(NDK_ROOT)/sources/cxx-stl/gnu-libstdc++/4.6/libs/armeabi-v7a/libgnustl_static.a

LOCAL_LDLIBS +=  -llog -ldl -lz


include $(BUILD_SHARED_LIBRARY)


저작자 표시 비영리 동일 조건 변경 허락
신고
Posted by Kugi
TAG android, JNI, NDK

댓글을 달아 주세요




안드로이드 프로젝트 테스트를 위해


새 프로젝트 만들기 메뉴의 [Android Project from Existing Code]로 안드로이드 프로젝트를 만드려고 하던 도중 다음과 같은 에러메시지가 떴다.


Error

Invalid project description


Reason:

Invalid project description.



[Details >>] 를 확인해보니 간단한 문제였다.


import 할 소스코드들을 프로젝트 디렉토리에 옮겨두고 새로운 프로젝트를 만드려고 시도해서


동일한 이름의 폴더가 이미 존재하기때문에 생긴 에러였다.


원본 폴더를 다른 폴더로 옮겨두고 다시 시도하니 문제없이 새로운 프로젝트가 생성되었다.



저작자 표시 비영리 동일 조건 변경 허락
신고
Posted by Kugi

댓글을 달아 주세요




안드로이드 폰에서 카메라 동영상을 연속적으로 촬영할 수 있도록 하기 위해 여러 인터넷 소스코드들을 실험해보던 도중


안드로이드펍에서 찾은 어느 소스[각주:1]를 돌려보았더니 MediaRecorder의 start() 부분에서 start failed 에러가 생겼다.


start failed: -19


구글링을 통해 다양한 해결 방법을 시도하다가 찾아낸 성공적인 해결 방법[각주:2]


setVideoFrameRate(...) 부분을 제거하는 것이었다.


내가 사용한 코드에는 프레임레이트 설정을 16으로 지정하도록 되어있었는데 이 부분을 주석처리하니 제대로 동작하였다.









  1. http://www.androidpub.com/431977 [본문으로]
  2. http://stackoverflow.com/a/11281902 [본문으로]
저작자 표시 비영리 동일 조건 변경 허락
신고
Posted by Kugi

댓글을 달아 주세요



티스토리 툴바